Internet Browser Requirements

Viewpoint Field View™ works with most current internet browsers.

Microsoft ended support for Internet Explorer 10 and older in January 2016. Viewpoint ended support for Internet Explorer 10 and older in Field View 2017-R6. We strongly recommend all customers use supported browsers, as unsupported browsers provide opportunity for malicious actors to capitalize on un-patched security holes. Post release of 2017-R6, users logging into Field View using IE10 or older may still be able to access the product but any issues specific to these versions of IE will not be addressed and new functionality may not be compatible.